Agent Plugin Update Issue

Incident Report for Tenable Inc

Resolved

The issue has been resolved. We are sorry for the disruption and inconvenience.
Posted Feb 18, 2025 - 09:18 EST

Monitoring

We have implemented a fix for the issue and are monitoring the recovery. Agents on 10.8.2 will recover to a healthy status as they check in throughout the day which may take up to 24 hours. The plugin feeds for all sites and all versions are restored.

To manually update the agent plugins available on Nessus Manager please refer to the manual plugin updates steps in the following link:
https://docs.tenable.com/nessus/Content/PluginAndSoftwareUpdates.htm
Posted Feb 12, 2025 - 17:07 EST

Update

The Tenable team is actively working on a fix for the Plugin Compilation Issue discovered on Nessus Agent version 10.8.2:
- Some customers may see Agents running version 10.8.2 return partial scan results.

The plugin feed has been resumed and all scanners and agents are once again able to receive updates with the exception of agents on version 10.8.2.
Posted Feb 12, 2025 - 15:46 EST

Update

The Tenable team is actively working on a fix for the Plugin Compilation Issue discovered on Nessus Agent version 10.8.2:
- Some customers may see Agents running version 10.8.2 return partial scan results.
- All plugin feed updates are currently disabled.

For customers that wish to recover sooner without waiting for the fix release, Tenable Vulnerability Management and Nessus Manager customers simply need to change the agent version to 10.7.3 under agent profiles.
Posted Feb 12, 2025 - 12:37 EST

Update

Tenable team is actively working on resolving the Plugin Compilation Issue discovered on Nessus Agent version 10.8.2:
- Some customers may see Agents running version 10.8.2 return partial scan results.
- All plugin feed updates are currently disabled.
Posted Feb 12, 2025 - 09:28 EST

Update

Our engineering team is continuing to work on a fix for this issue.
Posted Feb 12, 2025 - 06:56 EST

Update

Our engineering team is continuing to work on a fix for this issue.
Posted Feb 12, 2025 - 03:31 EST

Update

Our engineering team is continuing to work on a fix for this issue.
Posted Feb 12, 2025 - 01:40 EST

Update

Our engineering team is continuing to work on a fix for this issue.
Posted Feb 11, 2025 - 23:37 EST

Update

Our engineering team is continuing to work on a fix for this issue.
Posted Feb 11, 2025 - 21:27 EST

Identified

We have identified the cause of the problem. Our engineering team is working to implement a fix for the issue.
Posted Feb 11, 2025 - 18:54 EST

Update

We are continuing to investigate this issue.
Posted Feb 11, 2025 - 18:27 EST

Update

Our engineering team continues to investigate this issue.
Posted Feb 11, 2025 - 16:30 EST

Update

Our engineering team continues to investigate this issue.
Posted Feb 11, 2025 - 14:35 EST

Update

Our engineering team continues to investigate this issue.
Posted Feb 11, 2025 - 13:53 EST

Investigating

We are aware of and actively investigating agent issues that are impacting plugin updates for certain users. Agents are still able to perform their necessary tasks, including scanning, however plugin updates are currently turned off.

At this time the plugin feed has been disabled as our engineers continue working this issue. We will provide periodic updates as our engineers continue working on this issue.
Posted Feb 11, 2025 - 11:39 EST
This incident affected: Tenable Vulnerability Management (AP-SYD-1, BR01, CA01, FRA, IN01, JP01, SING, UAE01, UK-LON-1, US-1A, US-2A, US-2B, US-3A, US-4A, US-5A, US07, US08, GOV01) and Tenable Services (Tenable Plugin Feed Service).